Back to smode.fr
You are here: Tutorials > Procedural Terrain > Create a mountain from a displacement map

Create a mountain from a displacement map

Download texture files associated to this tutorial

All the textures you'll need for this tutorial are already in the smode's standard pack :

  • You can find them there exactly :

(To add new images or files, see Making your own compositions)

Create a new composition and a plane

Select your current project and create a new comp (File>New Standalone Compo) or Ctrl+N. In the dialog box, check Create Camera and Create Timeline. Your composition will automatically been seen as "Untitled compo" and placed under "Unsaved Documents", use File>Save or Ctrl+S to save your composition where you want.

 

Now we can start.

Create a plane with 3D Layers>Mesh>Plane.

We are going to create a mountain so a size of 500 meters per 500 meters seems allright, Precision will determine the poly numbers of the plane. For our purpose, a 256*256 level of precision seems allright.

Now that your plane is a huge motherfucker, to see it as on the screenshot below, you'll have to move your camera :

Alt+Click : rotate

Alt+Right Click or MouseWheel : Zoom

Alt + Middle click : Translate

F : Focuses camera on the currently selected object

Import the heightmap

Drag and Drop the file Smode_Heightmap.png from the file tree to the composition and then right click on it and select Share Image File. This Image has been made on smode with the particles system, but we’ll see that in an other tutorial.

Now you can keep the shared image (circled in red) and delete it's reference (the crossed one), this will result of keeping an image you'll be able to use later in a lot of different places. If you want to see what your shared Image/compositio looks like you can click on the little green triangle on it's left or simple click on it and move it somewhere in the tree, doing that you'll create a new reference of this shared content.

Create a Place modifier

Create a Place modifier over the 3D Layer plane. To do that, select the 3D Layer Plane and then select Modifiers>Distort>Place.

The Place modifier will allow you to displace your plane geometry but slightly differently than a regular Displace modifier, because unlike the latter, Place is world referenced and has rotation, translate and scale parameters.

Configure the displace with the map

Now we are going to put a mask on the Place modifier using image Heightmap.png To do that, just select the image from the element bank and ctrl + drag and drop it over the Place modifier. Now that the mask is created you’ll see that the layer mask and it’s generator are named [[Image_name.png]]. This means that this layer/generator is made with an instance of a shared element.

Now select the Place modifier and add a value wherever you want. I’ve added only a value of 200 into Y translation in this example.m

Your composition should now look like the image below:

Improve the displacement

Now you should notice that the displaced mesh is having some “stairs” that does not looks so nice. This happens because the image used as a displacement map is in 8bits per channels: with this precision, only 256 distincts levels of height can be encoded. Its possible to avoid this issue using a small blur. For that, select Smode_Heightmap.png shared element and:

  • Create a blur modifier with right click Modifiers>Blur>Blur.
  • Configure the blur in 16 bits by modifying it's Pixel Type like showed in the image below.
  • You have now a nice and shiny displaced mesh.

Bonus step: do what you want

You can add noises or whatever you want inside the displace map to shape the mountain as you want. To do that select Smode_Heightmap.png and then press Ctrl+Shift+C to transform your simple layer into a composition (and don’t forget to put this composition in 16bits in it's advanced mode parameters to avoid stairing artefacts, to do so, uncheck "automatic" inside the parameters).

In the example here I added a 2D Layer Chiseled Noise with the preset Caustics in Linear Dodge (add) blending mode at 20% Opacity, and disactivated the blur. Note that you can create a noise with the caustic's preset directly from the menu by clicking on this icon next to it :

Nb: I will not use this step for the remainder of this tutorial.

 

Next: Procedural texturing of the mountain